Slack outage

Incident Report for Datadog Integrations

Resolved

This incident has been resolved.
Posted May 14, 2026 - 11:38 EDT

Identified

We're aware that Slack is currently experiencing an incident affecting file uploads, message edits, channel renames, and channel creations. This is a Slack platform issue and their team is actively investigating.

For the latest status updates, please visit: https://slack-status.com/2026-05/fe557ca05fdb64fa

We appreciate your patience and will share any relevant updates as they become available.
Posted May 14, 2026 - 10:45 EDT