AWS outage in Bahrain and UAE

Incident Report for Datadog Integrations

Monitoring

As this is tied to the ongoing AWS issue, and since it’s within AWS infrastructure, we don’t have visibility into an ETA for resolution. We continue to actively monitor on our side and will share any updates if we see changes impacting Datadog services.

For the latest status, we recommend tracking the AWS Health Dashboard as they will continue to share updates there: https://health.aws.amazon.com/health/status
Posted Mar 03, 2026 - 08:35 EST

Identified

Some customers with AWS resources in the Bahrain or UAE data centers may be experiencing delayed or missing metrics, tags, resource collection, due to extensive AWS API failures.

We are waiting for AWS to provide an update - you can also directly check their status page : https://health.aws.amazon.com/health/status
Posted Mar 02, 2026 - 09:22 EST

Investigating

We are currently investigating an issue where some customers with AWS resources in the Bahrain or UAE data centers may be experiencing delayed or missing metrics, tags, resource collection, due to extensive AWS API failures.

Our engineering team is actively working to identify the exact impact and provide mitigation.
Posted Mar 02, 2026 - 03:00 EST
This incident affects: Amazon Web Services (AWS).