Pagerduty Monitor Notifications Delayed

Incident Report for Datadog Integrations

Resolved

PagerDuty notifications deliveries are back to normal.
Posted Aug 28, 2025 - 05:05 EDT

Update

We are observing some recovery of notifications delays and continue to monitor the situation.
Posted Aug 28, 2025 - 03:42 EDT

Update

We are continuing to observe delays in notifications delivery, PagerDuty has updated their status page https://status.pagerduty.com/posts/details/P0LKNIW
Posted Aug 28, 2025 - 02:31 EDT

Monitoring

We are continuing to observe delays in notifications delivery
Posted Aug 28, 2025 - 01:29 EDT

Investigating

Monitor Notifications are delayed for Pagerduty.
Posted Aug 28, 2025 - 00:47 EDT
This incident affected: Monitor notification methods (PagerDuty Notification Delivery).